(Space Cadet)
10/08/20 11:05 PM
VS-880EX SSD/CF/SATA conversion experience and why most current SD/CF and SD/IDE adapters do not work (always initializing at boot)


I am new here and have recently purchased a VS-880EX without a hard disk or HDP88/HDP88-DLE adapter . I have one on order, but who knows how long it will take to arrive from Japan . In the meantime, I have "Frankensteined" a workaround, using external power for now, by using a 50-pin SCSI cable, a makeshift 40-pin male to female adapter and an IDE to CF adapter . I have gotten an 8MB, a 128MB and an 8GB to initialize properly and to survive a power cycle .

With a few exceptions, everything else that I have tried either freezes the VS-880EX at boot or wants to re-initialize the disk after a power cycle, like in this old thread http://www.vsplanet.com/ubbthreads/ubbthreads.php?ubb=showflat&Number=1448252 . I now know what causes the re-initialization at boot and have documented my experiences, along with other tests, such as SATA SSDs and various CF card results, in detail on this external forum thread
https://www.vogons.org/viewtopic.php?f=62&t=76871 .

Shorter version of that vogons thread:

The re-initialization at boot happens with all (micro)SD to CF and SD to IDE adapters that I have tried (3 models so far) that are based on the FC1307 or FC1307A chip .

The issue occurs whenever the first primary partition on the "disk" is either FAT12 or FAT16 and the adapter is power-cycled .

This partition wiping behaviour can be reproduced even under Windows 10, for example, when

a)an FC1307(A) based adapter is connected (using an IDE USB adapter, a CF to USB adapter or even a SATA to USB adapter)
b)a FAT16 or FAT12 partition is created on the disk
c)optionally, the device is "safely removed"
d)the adapter is power cycled

It does not matter what other partitions, if any, are on the adapted disk, if the first primary partition is FAT12 or FAT16, the disk will be wiped upon power-cycle. Partition size is not a factor : I have tried 8MB and the out the of spec size of 4095MB and several values in between and the wiping always occurs .

However, if the first primary partition is not FAT12 or FAT16, no wiping will occur on power cycling, even if there are FAT16 or FAT12 partitions elsewhere on the disk . If there exist FC1307(A) based adapters without this issue, I would like to hear about them .

I see no possible workaround for the VS-880EX or likely any other VS-/VSR- device that use FAT12 or FAT16 partitions (the VS-880EX must find a FAT12 or FAT16 filesystem in the first primary partition, or it will not be happy).

The FC1306T based SD to IDE to SATA adapters that I have do not exhibit this issue. I imagine that other (micro)SD to IDE/CF adapters based on the FC1306T would likely work well too . Unfortunately, practically all (micro)SD to IDE/CF adapters on the market currently are based on the FC1370(A) chip which make them unsuitable for the VS-880EX .

I hope this ends up helping somebody .

10/08/20 11:14 PM
Re: VS-880EX SSD/CF/SATA conversion experience and why most current SD/CF and SD/IDE adapters do not work (always initializing at boot)

I'm sure it will help somebody(s). Thanks for posting this.
It's very interesting to know about.

(Space Cadet)
10/09/20 11:10 AM
Re: VS-880EX SSD/CF/SATA conversion experience and why most current SD/CF and SD/IDE adapters do not work (always initializing at boot)

I should probably have mentioned explicitly in this thread the results of my SSD tests .

Samsung 860 EVO SSDs and at least one old Sanforce SF2281 based SSD, when connected using an IDE to SATA bridge (JMicron JM20330 chip) were recognized by the VS-880EX.

I tested formatting with a 250GB Samsung 860 EVO and everything seems to work great, even after a power cyle. My only concern is current draw . I am currently testing with external power, as the Samsung has a max official peak power of 4W according to the web site (2.2W average), but the casing says 1.25A at 5V which means 6.25W . The power usage of the JM20330 bridge is likely very small, almost negligible .

According to official Roland docs, the most power hungry drive on the compatibility list is only 3.5W . The most power hungry 2.5" IDE drives that I have seen are 1A at 5V, so 5W .